KL801

Interfacing

By

Essay: 13. 7 Segment

Pengertian Seven Segment Display (Layar Tujuh Segmen)

Pengertian Seven Segment Display

Pengertian Seven Segment Display – Seven Segment Display (7 Segment Display) dalam bahasa Indonesia disebut dengan Layar Tujuh Segmen adalah komponen Elektronika yang dapat menampilkan angka desimal melalui kombinasi-kombinasi segmennya. Seven Segment Display pada umumnya dipakai pada Jam Digital, Kalkulator, Penghitung atau Counter Digital, Multimeter Digital dan juga Panel Display Digital seperti pada Microwave Oven ataupun Pengatur Suhu Digital . Seven Segment Display pertama diperkenalkan dan dipatenkan pada tahun 1908 oleh Frank. W. Wood dan mulai dikenal luas pada tahun 1970-an setelah aplikasinya pada LED (Light Emitting Diode).

Seven Segment Display memiliki 7 Segmen dimana setiap segmen dikendalikan secara ON dan OFF untuk menampilkan angka yang diinginkan. Angka-angka dari 0 (nol) sampai 9 (Sembilan) dapat ditampilkan dengan menggunakan beberapa kombinasi Segmen. Selain 0 – 9, Seven Segment Display juga dapat menampilkan Huruf Hexadecimal dari A sampai F. Segmen atau elemen-elemen pada Seven Segment Display diatur menjadi bentuk angka “8” yang agak miring ke kanan dengan tujuan untuk mempermudah pembacaannya. Pada beberapa jenis Seven Segment Display, terdapat juga penambahan “titik” yang menunjukan angka koma decimal.  Terdapat beberapa jenis Seven Segment Display, diantaranya adalah Incandescent bulbs, Fluorescent lamps (FL), Liquid Crystal Display (LCD) dan Light Emitting Diode (LED).

LED 7 Segmen (Seven Segment LED)

Salah satu jenis Seven Segment Display yang sering digunakan oleh para penghobi Elektronika adalah 7 Segmen yang menggunakan LED (Light Emitting Diode) sebagai penerangnya.  LED 7 Segmen ini umumnya memiliki 7 Segmen atau elemen garis dan 1 segmen titik yang menandakan “koma” Desimal. Jadi Jumlah keseluruhan segmen atau elemen LED sebenarnya adalah 8. Cara kerjanya pun boleh dikatakan mudah, ketika segmen atau elemen tertentu diberikan arus listrik, maka Display akan menampilkan angka atau digit yang diinginkan sesuai dengan kombinasi yang diberikan.

Terdapat 2 Jenis LED 7 Segmen, diantaranya adalah “LED 7 Segmen common Cathode” dan “LED 7 Segmen common Anode”.

LED 7 Segmen Tipe Common Cathode (Katoda)

Pada LED 7 Segmen jenis Common Cathode (Katoda), Kaki Katoda pada semua segmen LED adalah terhubung menjadi 1 Pin, sedangkan Kaki Anoda akan menjadi Input untuk masing-masing Segmen LED.  Kaki Katoda yang terhubung menjadi 1 Pin ini merupakan Terminal Negatif (-) atau Ground sedangkan Signal Kendali (Control Signal) akan diberikan kepada masing-masing Kaki Anoda Segmen LED.LED Seven Segment Display Tipe Common Katoda

LED 7 Segmen Tipe Common Anode (Anoda)

Pada LED 7 Segmen jenis Common Anode (Anoda), Kaki Anoda pada semua segmen LED adalah terhubung menjadi 1 Pin, sedangkan kaki Katoda akan menjadi Input untuk masing-masing Segmen LED. Kaki Anoda yang terhubung menjadi 1 Pin ini akan diberikan Tegangan Positif (+) dan Signal Kendali (control signal) akan diberikan kepada masing-masing Kaki Katoda Segmen LED.LED Seven Segment Display Tipe Common Anoda

Prinsip Kerja Dasar Driver System pada LED 7 Segmen

Berikut ini adalah Blok Diagram Dasar untuk mengendalikan LED 7 Segmen :Blok Diagram Seven Segment Display

Blok Dekoder pada diagram diatas mengubah sinyal Input yang diberikan menjadi 8 jalur yaitu “a” sampai “g” dan poin decimal (koma) untuk meng-ON-kan segmen sehingga menghasilkan angka atau digit yang diinginkan. Contohnya, jika output dekoder adalah a, b, dan c, maka Segmen LED akan menyala menjadi angka “7”.   Jika Sinyal Input adalah berbentuk Analog, maka diperlukan ADC (Analog to Digital Converter) untuk mengubah sinyal analog menjadi Digital sebelum masuk ke Input Dekoder. Jika Sinyal Input sudah merupakan Sinyal Digital, maka Dekoder akan menanganinya sendiri tanpa harus menggunakan ADC.

Fungsi daripada Blok Driver adalah untuk memberikan arus listrik yang cukup kepada Segmen/Elemen LED untuk menyala. Pada Tipe Dekoder tertentu, Dekoder sendiri dapat mengeluarkan Tegangan dan Arus listrik yang cukup untuk menyalakan Segmen LED maka Blok Driver ini tidak diperlukan. Pada umumnya Driver untuk menyalakan 7 Segmen ini adalah terdiri dari 8 Transistor Switch pada masing-masing elemen LED.

Tabel Pengaktifan Seven Segment Display

ANGKA h g f e d c b a
0 0 0 1 1 1 1 1 1
1 0 0 0 0 0 1 1 0
2 0 1 0 1 1 0 1 1
3 0 1 0 0 1 1 1 1
4 0 1 1 0 0 1 1 0
5 0 1 1 0 1 1 0 1
6 0 1 1 1 1 1 0 1
7 0 0 0 0 0 1 1 1
8 0 1 1 1 1 1 1 1
9 0 1 1 0 1 1 1 1

Catatan :

1 = ON (High)
0 = OFF (Low)

berikan contoh penggunaan 7 Segment dalam rangkaian ATmega8 / ATmega8535 sebagai display,

berikan juga contoh programnya.

Seven segment merupakan penampil yang setingkat dengan LED, hanya saja seven segment dapat menampilkan data ke bentuk karakter. Dalam pemrogrmannya, seven segment harus diberi data khusus agar dapat terbentuk karakter tertentu. Oleh karena itu harus diperhatikan hardware yang terpasang. Ada dua tipe pengaplikasian seven segement yaitu common anode atau common katode. Untuk percobaan kali ini menggunakan single seven segment dengan konfigurasi common anode seperti gambar dibawah ini:

Aplikasi Seven Segment dengan simulasi program PROTEUS

Data Karakter Angka Pada Seven Segment

Pemrograman Seven Segment dengan Bascom AVR

Program berikut ini digunakan untuk menampilkan angka 5 dan 7. Diantara data yang di keluarkan pada port A tersebut terdapat waktu tunda kurang lebih 1000 milisekon ato 1 detik. Didalam program utama terdapat pernyataan “do loop”. Pernyataan itu berfungsi untuk melakukan looping  secara terus menerus.

Result:

 

By

Essay: 12. LCD

Pelajari tentang LCD, pengertian pada pin -pin LCD dan penggunaannya,

berikan contoh penggunaan LCD dalam rangkaian ATmega8 / ATmega8535 sebagai display,

berikan juga contoh programnya.

1.Pin – Pin yang dipergunakan pada LCD

Fungsi Pin LCD (Liquid Cristal Display) Dot Matrix 2×16 M1632 DB0 – DB7 adalah jalur data (data bus) yang berfungsi sebagai jalur komunikasi untuk mengirimkan dan menerima data atau instruksi dari mikrokontrooler ke modul LCD. RS adalah pin yang berfungsi sebagai selektor register (register sellect) yaitu dengan memberikan logika low (0) sebagai register perintah dan logika high (1) sebagai register data. R/W adalah pin yang berfungsi untuk menentukan mode baca atau tulis dari data yang terdapat pada DB0 – DB7. Yaitu dengan memberikan logika low (0) untuk fungsi read dan logika high (1) untuk mode write. Enable (E), berfungsi sebagai Enable Clock LCD, logika 1 setiap kali pengiriman atau pembacaan data.

2.Bagaimana pemasangan pin-pin LCD pada ATmega8535 dan cara pemrograman pin-pin tersebut.

1. Kaki 1 dan 16 terhubung dengan Ground (GND)

2. Kaki 2 dan 15 terhubung dengan VCC (+5V)

3. Kaki 3 dari LCD 16×2 adalah pin yang digunakan untuk mengatur kontras kecerahan LCD. Jadi kita bisa memasangkan sebuah trimpot 103 untuk mengatur kecerahanya. Pemasanganya seperti terlihat pada rangkaian tersebut. Karena LCD akan berubah kecerahanya jika tegangan pada pin 3 ini di turunkan atau dinaikan.

4. Pin 4 (RS) dihubungkan dengan pin mikrokontroler

5. Pin 5 (RW) dihubungkan dengan GND

6. Pin 6 (E) dihubungkan dengan pin mikrokontroler

7. Sedangkan pin 11 hingga 14 dihubungkan dengan pin mikrokontroler sebagai jalur datanya.

3.Bagaimana menampilkan character pd LCD yang diprogram dari ATmega8535

LCD (Liquid Crystal Display) adalah modul penampil yang banyak digunakan karena tampilannya menarik. LCD yang paling banyak digunakan saat ini ialah tipe M1632 karena harganya cukup murah. LCD M1632 merupakan modul LCD dengan tampilan 2×16 (2 baris x 16 kolom) dengan konsumsi daya rendah. Modul tersebut dilengkapi dengan mikrokontroler yang didesain khusus untuk mengendalikan LCD.

Untuk rangkaian interfacing, LCD tidak banyak memerlukan komponen pendukung. Hanya diperlukan satu variable resistor untuk memberi tegangan kontras pada matriks LCD.

Dengan menggunakan CodeVision AVR, pemrograman untuk menampilkan karakter atau string ke LCD sangat mudah karena didukung library yang telah disediakan oleh CodeVision AVR itu sendiri. Kita tidak harus memahami karakteristik LCD secara mendalam, perintah tulis dan inisialisasi sudah disediakan oleh library dari CodeVision AVR.

A. Pin – Pin yang dipergunakan pada LCD

– Pin data adalah jalur untuk memberikan data karakter yang ingin ditampilkan menggunakan LCD (Liquid Cristal Display) dapat dihubungkan dengan bus data dari rangkaian lain seperti mikrokontroler dengan lebar data 8 bit.

– Pin RS (Register Select) berfungsi sebagai indikator atau yang menentukan jenis data yang masuk, apakah data atau perintah. Logika low menunjukan yang masuk adalah perintah, sedangkan logika high menunjukan data.

– Pin R/W (Read Write) berfungsi sebagai instruksi pada modul jika low tulis data, sedangkan high baca data.

– Pin E (Enable) digunakan untuk memegang data baik masuk atau keluar.

– Pin VLCD berfungsi mengatur kecerahan tampilan (kontras) dimana pin ini dihubungkan dengan trimpot 5 Kohm, jika tidak digunakan dihubungkan ke ground, sedangkan tegangan catu daya ke LCD sebesar 5 Volt.

B. Bagaimana pemasangan pin-pin LCD pada ATmega8535 dan cara pemrograman pin-pin tersebut.

dari gambar tersebut dapat dilihat bahwa LCD 16×2 mempunya 16 pin. sedangkan pengkabelanya adalah sebagai berikut :

1. Kaki 1 dan 16 terhubung dengan Ground (GND)

2. Kaki 2 dan 15 terhubung dengan VCC (+5V)

3. Kaki 3 dari LCD 16×2 adalah pin yang digunakan untuk mengatur kontras kecerahan LCD. Jadi kita bisa memasangkan sebuah trimpot 103 untuk mengatur kecerahanya. Pemasanganya seperti terlihat pada rangkaian tersebut. Karena LCD akan berubah kecerahanya jika tegangan pada pin 3 ini di turunkan atau dinaikan.

4. Pin 4 (RS) dihubungkan dengan pin mikrokontroler

5. Pin 5 (RW) dihubungkan dengan GND

6. Pin 6 (E) dihubungkan dengan pin mikrokontroler

7. Sedangkan pin 11 hingga 14 dihubungkan dengan pin mikrokontroler sebagai jalur datanya.

C. Bagaimana menampilkan character pd LCD yang diprogram dari ATmega8535

Susunan alamat pada LCD

Alamat awal karakter 00H dan alamat akhir 39H. Jadi, alamat awal di baris kedua dimulai dari 40H. Jika Anda ingin meletakkan suatu karakter pada baris ke-2 kolom pertama, maka harus diset pada alamat 40H. Jadi, meskipun LCD yang digunakan 2×16 atau 2×24, atau bahkan 2×40, maka penulisan programnya sama saja.

CGRAM merupakan memori untuk menggambarkan pola sebuah karakter, dimana bentuk dari karakter dapat diubah-ubah sesuai dengan keinginan. Namun, memori akan hilang saat power supply tidak aktif sehingga pola karakter akan hilang. Berikut tabel pin untuk LCD M1632. Perbedaannya dengan LCD standar adalah pada kaki 1 VCC, dan kaki 2 Gnd. Ini kebalikan dengan LCD standar.
Susunan kaki pada LCD

Perlu diketahui, driver LCD seperti HD44780 memiliki dua register yang aksesnya diatur menggunakan pin RS. Pada saat RS berlogika 0, register yang diakses adalah perintah, sedangkan pada saat RS berlogika 1, register yang diakses adalah register data.

$regfile = “8535def.dat”
$crystal = 4000000

Config Lcdpin = Pin , Db4 = Porta.5 , Db5 = Porta.4 , Db6 = Porta.3 , Db7 = Porta.2 , E = Porta.1 , Rs = Porta.0

Config Lcd = 16 * 2

Do
Cls
Locate 1 , 1
Lcd “Pengenalan”
Waitms 100
Locate 2 , 1
Lcd “Pemograman”
Waitms 100
cls
Locate 1 , 4
Lcd “ATMEGA8535″
Waitms 100
Locate 2 , 1
Lcd “Dengan BASCOM-AVR”
Waitms 100
Cls
Locate 1 , 1
Lcd “BY”
Locate 2 , 1
Lcd “Frengki”
Waitms 100
Loop

Pembahasan Program :

$regfile = “8535def.dat” library yang menyatakan bahwa mikrokontroller yang kita pakai adalah atmega32,
$crystal = 4000000 meyatakan bahwa clock oscillator yang kita pakai sebesar 8Mhz,
Config Lcdpin = Pin , Db4 = Porta.5 , Db5 = Porta.4 , Db6 = Porta.3 , Db7 = Porta.2 , E = Porta.1 , Rs = Porta.0 inisialisasi pin-pin pada LCD sendiri,
Config Lcd = 16 * 2 LCD yang kita pakai adalah LCD berukuran 20*4,
Cls = LCD dibersihkan terlebih dahulu
Locate 1 , 1 = menyatakan huruf atau angka yang akan ditampilkan pertama kali akan keluar pada kolom 1 baris 1,
Lcd “Pengenalan” = kata yang akan ditampilkan pada LCD adalah “pengenalan”

By

Serial Pheripheral Interface (SPI) dan Universal Synchronous Asynchronous Receiver Transmitter (USART) pada ATmega8 / ATmega8535 dan bagaimana penggunaannya, berikan contoh implementasinya termasuk software yang digunakan.

Serial Peripheral Interface ( SPI ) merupakan salah satu mode komunikasi serial synchrounous kecepatan tinggi yang dimiliki oleh ATmega 328. Komunikasi SPI membutuhkan 3 jalur yaitu MOSI, MISO, dan SCK. Melalui komunikasi ini data dapat saling dikirimkan baik antara mikrokontroller maupun antara mikrokontroller dengan peripheral lain di luar mikrokontroller Penjelasan 3 jalur utama dari SPI adalah sebagai berikut :

>MOSI : Master Output Slave Input Artinya jika dikonfigurasi sebagai master maka pin MOSI sebagai output tetapi jika dikonfigurasi sebagai slave maka pin MOSI sebagai input.

MISO : Master Input Slave Output Artinya jika dikonfigurasi sebagai master maka pin MISO sebagai input tetapi jika dikonfigurasi sebagai slave maka pin MISO sebagai output.

CLK : Clock Jika dikonfigurasi sebagai master maka pin CLK berlaku sebagai output tetapi jika dikonfigurasi sebagai slave maka pin CLK berlaku sebagai input.

Untuk mengatur mode kerja komunikasi SPI ini dilakukan dengan menggunakan register SPCR (SPI Control Register), SPSR (SPI Status Register) dam SPDR (SPI Data Register) SPI Control Register (SPCR) Mode SPCR yang digunakan adalah sebagai berikut : Bit-6 SPE (SPI Enable) SPE digunakan untuk mengaktifkan dan menonaktifkan komunikasi SPI dimana jika SPI bernilai 1 maka komunikasi SPI aktif sedangkan jika bernilai 0 maka komunikasi SPI tidak aktif. Bit-4 MSTR (Master or Slave Select) MSTR digunakan untuk mengkonfigurasi sebagai master atau slave secara software dimana jika MSTR bernilai 1 maka terkonfigurasi sebagai master sedangkan MSTR bernilai 0 maka terkonfigurasi sebagai slave. Pengaturan bit MSTR ini tidak akan bisa dilakukan jika pin SS dikonfigurasi sebagai input karena jika pin SS dikonfigurasi sebagai input maka penentuan master atau slavenya otomatis dilakukan secara hardware yaitu dengan membaca level tegangan pada SS Bit-1 SPR1/0 (SPI Clock Rate Select) SPR1 dan SPR0 digunakan untuk menentukan kecepatan clock yang digunakan dalam komunikasi SPI. SPI Status Register (SPSR) Dalam SPSR mode pengaturan yang dilakukan adalah sebagai berikut : SPIF (SPI Interrupt Flag) SPIF merupakan bendera yang digunakan untuk mengetahui bahwa proses pengiriman data 1 byte sudah selesai. Jika proses pengiriman data sudah selesai maka SPIF akan bernilai satu (high). SPI Data Register (SPDR) SPDR merupakan register yang digunakan untuk menyimpan data yang akan dikirim atau diterima pada komunikasi SPI.

Pengenalan USART ATmega8535 USART (Universal Syschronous Asynchronous Received Transmitter) merupakan salah satu mode komunikasi yang dimiliki oleh Mikrokontroler ATMega8535. USART memiliki 2 pin (RxD dan TxD) untuk Asynchronous dan 3 bit TxD, RxD, xCK untuk Synchronous. Untuk mengatur komunikasi USART dilakukan melalui beberapa register yaitu : UDR (USART Data Register) adalah register yang paling penting dalam komunikasi serial ini. Sebab data yang dikirim keluar harus ditempatkan pada register ini, sedang data yang diterima dari luar dapat dibaca pada register ini pula. Pada intinya register UDR digunakan sebagai buffer untuk menyimpan data, baik yang akan dikirim maupun yang akan diterima. image Seperti yang dapat dilihat pada gambar, sejatinya UDR adalah terdiri dari 2 buah register terpisah, dengan alamat dan nama yang sama, yakni UDR. Saat kita menulis data pada UDR ini, maka sebenarnya kita menulis data pada UDR (Write) yang kemudian USART mem-frame dengan bit-bit frame dan segera akan segera mengirimkan data tersebut secara serial. Saat kita membaca UDR, sebenarnya adalah membaca UDR (Read). Data yang diterima secara serial akan disimpan dalam register tersebut, setelah hadirnya stop bit, maka USART akan membuang frame dan menyiapkan data pada UDR (Read ) sehingga dapat segera di ambil. Kita dapat menggunakan instruksi OUT dan IN untuk menulis dan membaca register UDR ini. UCSRA (USART Control dan Status Register A) adalah register yang penting. Sebegian besar adalah berisi status dari dari proses transfer komunikasi serial itu sendiri. Adapun penjelasan dari bit-bit tersebut adalah:

image

Bit 7 – RxC: USART Receive Complete Bit ini menjadi tinggi jika ada data yang masih belum diambil atau dibaca di dalam buffer penerima ( UDR-read ). Bit ini akan otomatis rendah setelah buffer penerima telah dibaca. Jika Unit Penerima tiba-tiba dimatikan setelah diaktifkan, maka isi dalam buffer penerima akan langsung dibuang (flushed) dan bit RxC ini akan langsung dibuat rendah. Bit ini juga bisa mengaktifkan instrupsi “Receive Complete interrupt ”. Lihat penjelasan tentang bit RxCIE. Untuk mengetahui penerimaan data jika high (1) ada data baru dan jika low (0) tidak ada data baru. Bit 6 – TxC: USART Transmit Complete Bit ini akan otomatis tinggi saat semua frame dalam shift-register pengiriman telah digeser semuanya keluar dan jika tidak ada data baru yang berarada dalam buffer pengiriman (UDR-write). Bit TxC ini akan otomatis rendah setelah “Transmit Complete interrupt ” dijalankan, atau dengan meng-clearkan secara manual dengan cara menulis bit ini dengan nilai 1’s (tinggi). Bit TxC ini pula dapat membangkitan “Transmit Complete interrupt ”. Lihat penjelasan tentang bit TxCIE. Untuk mengetahui pengiriman data, jika high (1) ada data baru dan jika low (0) tidak ada data baru. Bit 5 – UDRE: USART Data Register Empty Bit UDRE ini adalah untuk menjadikan tanda jika buffer pengiriman (UDR-write) telah siap untuk diberikan data baru. Bit ini akan bernilai 1 (tinggi) , berarti kita saat itu boleh menulis UDR. Bit ini dapat membangkitkan UDRIE atau “Data Register Empty interrupt ”. Lihat penjelasan tentang bit UDRIE. Bit ini setelah reset langsung bernilai 1, yang berarti siap untuk melakukan pengiriman. Bit 4 – FE: Frame Error Bit ini otomatis menjadi tinggi jika saat menerima data, ternyata ada kesalahan dari frame yang diterima. Misalnya saat Unit penerima seharusnya menunggu sebuah bit Stop, ternyata data yang ada adalah 0 (rendah). Bit ini valid setelah kita membaca UDR. Harap selalu menulis bit ini dengan 0 (rendah ) saat kita sedang menulis UCSRA. Bit 3 – DOR: Data OverRun Bit ini akan menjadi tinggi saat kondisi overrun terjadi. Kondisi ini terjadi saat buffer penerima sudah penuh dan berisi 2 data karakter, dimana data karakter terakhir tidak bisa dipindahkan ke UDR-read, karena tidak kunjung dibaca oleh user. Bit ini valid setelah kita membaca UDR. Harap selalu menulis bit ini dengan 0 (rendah ) saat kita sedang menulis UCSRA. Bit 2 – PE: Parity Error Bit ini akan menjadi tinggi saat karakter yang sedang diterima ternyata memiliki format parity yang salah. Tentu saja hal ini terjadi jika bit parity checking diaktifkan (UPM1 = 1). Bit ini valid setelah kita membaca UDR. Harap selalu menulis bit ini dengan 0 (rendah ) saat kita sedang menulis UCSRA. Bit 1 – U2X: Double the USART Transmission Speed Bit ini hanya berlaku untuk operasi tak sinkron (asynchronous). Jika bit ini kita tulis dengan 1’s (tinggi) maka baud rate akan menjadi lebih cepat 2 kali. Hal itu terjadi karena pembagi baud rate yang biasanya membagi 16 kemudian menbagi menjadi dengan 8 saja. Tulis bit ini dengan 0’s (rendah) untuk oprasi sinkron (synchronous). Bit 0 – MPCM: Multi-processor Communication Mode Bit ini digunakan untuk mode komunikasi Multi-Prosesor. Saat bit PMCM ini dibuat menjadi tinggi maka setiap data yang diterima oleh unit penerima, namun tidak dilengkapi dengan informasi alamat, data yang benar, maka akan diabaikan. Bit ini hanya berguna untuk penerima, dan bukan untuk pengirim. UCSRC (USART Control dan Status Register C) regsiter ini adalah register penting, untuk melakukan kontrol pada peralatan USART. Namuin jika tidak menggunakan fungsi USART, maka boleh mengabaikan register ini seperti dalam keadaan resetnya. dengan nilai $96, yang berarti bahwa sedang meggunakannya sebagai UART, Parity-none, 1 stop bit, ukuran data 8-bit (UCSZ2 = 0).

image

Catatan : Register UCSRC adalah berbagi alamat I/O yang sama dengan register UBBRH. Lihat bagaimana mengakses UBBRH dan UCSRC pada “Accessing UBRRH/UCSRC Registers” untuk mendapatkan penjelasan lebih lengkap. Bit 7 – URSEL: Register Select Saat akan menulis port $20 maka ada dua register yang akan akan diakses, yang ditentukan dari D7 dari data yang dituliskan. Jika D7 (MSB) adalah 1 atau datanya diatas $80 maka sedang menuliskan data pada UCSRC. Sedang jika data yang hendak dituliskan adalah dibawah $80, maka kita sedang menulis UBRRH. Bagaimana saat membaca UCSRC, pastikan sebelumnya bit ini dalam keadaan tinggi sebelumnya membaca lokasi $20 ini. Bit 6 – UMSEL: USART Mode Select Bit ini untuk memilih USART dijadikan mode Taksinkron (Asynchronous) atau Sinkron (Synchronous).

Bit 5:4 – UPM1:0: Parity Mode Bit-bit ini adalah untuk menghidupkan pembangkit dan pemeriksa parity. Jika diaktifkan maka akan otomatis membangkitkan parity pada setiap data yang dikirimkan dan akan memeriksa validitas parity dari setiap data yang diterima. Pada Unit penerima kita akan mendapatkan parity yang diterima, kemudian parity tersebut akan dibandingkan dengan status dari UMP0. Jika ternyata tidak cocok, maka bendera bit PE (Parity Error) pada UCSRA akan diaktifkan.

Hasil gambar

 

Bit 3 – USBS: Stop Bit Select Dengan membiarkan bit in menjadi 0 maka frame akan dilengkapi dengan Stop-bit selebar 1-bit. Sedang jika bit ini ditulis tinggi, maka bit stop menjadi 2-bit. Stop bit sepanjang 2-bit ini biasanya diperlukan bagi system lain yang terhubung dengan AVR akan memiliki waktu yang cukup untuk memproses data yang baru saja diterimanya, dan sudah berar-benar siap untuk menerima data berikutnya. Unit penerima USART tidak menggunakan bit ini.

Bit 2:1 – UCSZ1:0: Character Size Menentukan karakter dari data yang hendak dikirimkan dan diterima haruslah merujuk pada bit-bit ini. Yakni bit UCSZ1 dan bit UCSZ0 milik register ini. Ditambah dengan bit UCSZ2 pada register UCSRB.

Bit 0 – UCPOL: Clock Polarity Bit ini hanya digunakan pada mode Synchronous. Dalam mode ini akan direlasikan antara daya yang diterima dan data yang dikirm dan disinkronkan dengan status dari XCX (synchronous clock). Perhatikan tabel 5 untuk mendalami bagaimana singkronikasi terjadi untuk ujung XCX (edge) yang berbeda dengan mengatur bit UCPOL ini.

Hasil gambar untuk Tabel Pengaturan Polaritas Dalam Mode Synchronous

Pemrograman AVR SPI dengan Codevision

Buka projeck baru, gunakan codewizard

set icon sebagai master

Fungsi Mengirim data: SPI(char data)

Menerima data: char hasil = SPI(0)

Contoh Program membuat Voltmeter dgn SPI ADC   AD7896  12 bit   :

Rangkaian

Koneksi SPI   ADC dan AVR

By

VLAN pada switch Cisco 2960 Series dan hubungannya dengan Sub-interface pada router Cisco 2621xm. Berikan contoh configurasinya ( menggunakan IP class C )

VLAN atau Virtual Local Area Network adalah sebuah interface yang dapat membuat beberapa segmen ip dalam satu switch manageable atau router. Jika pada pendekatan tradisional satu port LAN hanya bisa diberi satu nilai IP, pada VLAN satu port LAN dapat memiliki interface virtual yang biasa disebut VLAN, dengan pendekatan ini memungkinkan menggunakan banyak ip dalam satu port LAN pada router.

pada prakteknya suatu vlan harus bisa berkomunikasi dengan vlan lain contohnya antara vlan divisi dengan vlan pada group server.  Dengan adanya kondisi seperti itu maka diperlukan Router yang memiliki fitur subinterface untuk memungkinkan terjadinya intervlan communication.

Penambahan sub-interface suatu vlan harus bisa berkomunikasi dengan vlan lain contohnya antara vlan divisi dengan vlan pada group server. Dengan adanya kondisi seperti itu maka diperlukan Router yang memiliki fitur subinterface untuk memungkinkan terjadinya intervlan communication.pada VLAN, ini sesuai dengan banyaknya VLAN yang akan ditangani.

contoh configurasinya (menggunakan IP class C)

Pertama pasang cable console ke switch dan hubungkan ke PC pada port serial, kemudian kalo pake windows XP buka aplikasi Hyper terminal

 

pilih com1 lalu klik OK
Pilih bits per second 9600, databits 8, parity none, stop bits 1, parity control none klik OK

Kemudian isi terminal misalkan “switch” klik OK

 

Pilih bits per second 9600, databits 8, parity none, stop bits 1, parity control none klik OK

Press RETURN to get started!
tekan enter…
Switch>
Switch>enable
Switch#clock set 12:45:00 12 October 2014
Switch#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname Testing
Testing(config)#enable secret cisco123
Testing(config)#line vty 0 4
Testing(config-line)#password cisco
Testing(config-line)#login
Testing(config-line)#exit
Testing(config)#interface vlan 1
Testing(config-if)#ip address 192.168.1.10 255.255.255.0
Testing(config-if)#no shutdown
%LINK-5-CHANGED: Interface Vlan1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
Testing(config-if)#
Testing(config)#int fa0/1
Testing(config-if)#duplex ?
auto Enable AUTO duplex configuration
full Force full duplex operation
half Force half-duplex operation
Testing(config-if)#duplex full
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Testing(config-if)#speed ?
10 Force 10 Mbps operation
100 Force 100 Mbps operation
auto Enable AUTO speed configuration
Testing(config-if)#speed auto
Testing(config-if)#description koneksi Server Email
Testing(config-if)#no shutdown
Testing(config-if)#exit
Testing(config)#int fa0/2
Testing(config-if)#duplex full
%LINK-5-CHANGED: Interface FastEthernet0/2, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
Testing(config-if)#speed auto
Testing(config-if)#description koneksi Server Dns
Testing(config-if)#no shutdown
Testing(config-if)#exit
Testing(config)#exit
Testing#copy running-config startup-config
Destination filename [startup-config]?
Building configuration…
[OK]
Testing#

Untuk mengecek bisa mengetikan perintah
show ?
show running-config
show interface status
show interface summary
show host

 

By

Essay: 4. Ringkasan Interface dan Sub-interface pada Cisco Router

Cara memberikan IP Address pada interface and sub-interface bisa dengan cara Konfigurasi Static Routing pada Packet Tracer, Berikut adalah contoh konfigurasi static routing menggunakan Packet Tracert. Dibutuhkan 3 Router, 3 Switch, dan 6 PC. Berikut ini akan di jelaskan bagaimana konfigurasi hingga semua device terkoneksi.

 

Contoh bentuk topologinya :

image

Layout :

Router ke router : Serial

Router ke switch : FastEthernet (boleh pake Ethernet tapi lebih cepat FastEthernet)

Switch ke PC : FastEthernet

Konektor yang warna merah menggunakan Serial DCE, jadi saat konfigurasi harus disertakan clock rate 64000. Jika menggunakan Serial DTE tidak perlu clock rate.

(recommended) Sebaiknya menggunakan Routers yang Generic (Router-PT) agar kita tidak perlu menambahkan modul pada komponen router.

(recommended) Untuk Switches gunakan Generic (Switch-PT)

Konfigurasi ini menggunakan CLI (command-line interface)

 

 

Setting router

1. ROUTER 0 (setting 1 serial, 1 FastEthernet)

Router>en // enable

Router#conf t //configure terminal

Router(config)#int fa0/0 //setting interface dari router ke switch

Router(config-if)#ip add 192.168.1.1 255.255.255.0 //setting IP dan subnet mask

Router(config-if)#no shut //mengaktifkan setting diatasnya

Router(config-if)#ex //exit

Router(config)#

Router(config)#int s2/0 //setting interface serial di router 0

Router(config-if)#ip add 192.168.4.1 255.255.255.0

Router(config-if)#clock rate 64000 //kecepatan clock

Router(config-if)#no shut

Router(config-if)#ex

 

 

1. ROUTER 1 (setting 2 serial, 1 FastEth)

Router>en

Router#conf t

Router(config)#int fa0/0

Router(config-if)#ip add 192.168.2.1 255.255.255.0

Router(config-if)#no shut

Router(config-if)#ex

Router(config)#

Router(config)#int s2/0

Router(config-if)#ip add 192.168.4.2 255.255.255.0

Router(config-if)#clock rate 64000

Router(config-if)#no shut

Router(config-if)#ex

Router(config)#

Router(config)#int s3/0

Router(config-if)#ip add 192.168.5.1 255.255.255.0

Router(config-if)#clock rate 64000

Router(config-if)#no shut

Router(config-if)#ex

 

ROUTER 2 (setting 1 serial, 1 FastEth)

Router>en

Router#conf t

Router(config)#int fa0/0

Router(config-if)#ip add 192.168.3.1 255.255.255.0

Router(config-if)#no shut

Router(config-if)#ex

Router(config)#

Router(config)#int s2/0

Router(config-if)#ip add 192.168.5.2 255.255.255.0

Router(config-if)#clock rate 64000

Router(config-if)#no shut

Router(config-if)#ex

Gimana mudah kan? Tunggu dulu kita belum selesai settingnya. Kita perlu setting routingnya, yang diatas itu hanya setting masing-masing router. INGAT! Routing berbeda dengan router.

 

Cara setting routing :

Router0:

Router(config)#ip route 192.168.2.0 255.255.255.0 192.168.4.2 //

Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.4.2

 

Router1 :

Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.4.1

Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.5.2

 

Router2 :

Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.5.1

Router(config)#ip route 192.168.2.0 255.255.255.0 192.168.5.1

 

Memberi IP pada masing-masing PC

Klik image PC

Klik Tab Desktop

Pilih IP Configuration

Ulangi hingga PC5

image

Daftar IP Address dan Default Gateway :

image

Sub Interface cisco

Configurasi Sub Interface cisco

 

ENCAP :
fa0/0.10 172.10.10.254 255.255.255.0
fa0/0.10 172.20.20.254 255.255.255.0
fa0/0.10 172.30.30.254 255.255.255.0

Untuk konfigurasi soal di samping anda bisa mengikuti langkah-langkah berikut ini :

KONFIGURASI PADA ROUTER :

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int fa0/0.10
Router(config-subif)#encap dot1Q 10
Router(config-subif)#ip add 172.10.10.254 255.255.255.0
Router(config-subif)#no shut
Router(config-subif)#
======================================
Router(config-subif)#EX
Router(config)#int fa0/0.20
Router(config-subif)#encap dot1Q 20
Router(config-subif)#ip add 192.20.20.254 255.255.255.0
Router(config-subif)#no shut
Router(config-subif)#
======================================
Router(config-subif)#EX
Router(config)#int fa0/0.30
Router(config-subif)#encap dot1Q 30
Router(config-subif)#ip add 172.30.30.254 255.255.255.0
Router(config-subif)#no shut
Router(config-subif)#

SETTING FA0/0 DAN ROUTER RIP

Router(config)#int fa0/0
Router(config-if)#ip add 172.40.40.1 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up

%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up

%LINK-5-CHANGED: Interface FastEthernet0/0.30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.30, changed state to up

Router(config-if)#ex
Router(config)#router rip
Router(config-router)#net 172.10.10.0
Router(config-router)#net 172.20.20.0
Router(config-router)#net 172.30.30.0
Router(config-router)#

KONFIGURASI PADA SWITCH :

Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vtp mode server
Device mode already VTP SERVER.
Switch(config)#vtp domain fti
Changing VTP domain name from NULL to fti
Switch(config)#vtp pass cisco5
Setting device VLAN database password to cisco5
Switch(config)#vlan 10
Switch(config-vlan)#name VLAN_10
Switch(config-vlan)#ex
Switch(config)#vlan 20
Switch(config-vlan)#name VLAN_20
Switch(config-vlan)#ex
Switch(config)#vlan 30
Switch(config-vlan)#name VLAN_30
Switch(config-vlan)#ex
Switch(config)#
======================================
Switch(config)#int range fa0/1-3
Switch(config-if-range)#swit mode access
Switch(config-if-range)#ex
Switch(config)#int fa0/1
Switch(config-if)#swit acc vlan 10
Switch(config-if)#ex
Switch(config)#int fa0/2
Switch(config-if)#swit acc vlan 20
Switch(config-if)#ex
Switch(config)#int fa0/3
Switch(config-if)#swit acc vlan 30
Switch(config-if)#ex
Switch(config)#

Jika konfigurasi sudah benar maka bida di tes dengan mengirimkan paket dari PC0 ke PC1 atau sebaliknya, PC0 ke PC2 atau sebaliknya, dan PC0 PC1 PC2 ke router.
hasilnya adalah :

Jaringan frame relay Sub-Interface memungkinkan kita memakai satu interface fisik router yang sama untuk beberapa virtual circuit. Hal ini merupakan penghematan yang sangat besar dalam menyediakan suatu interface tunggal yang bisa dipakai untuk beberapa koneksi WAN. Hal ini juga bisa mengatasi berbagai masalah koneksi yang berhubungan dengan operasi normal dari protocol routing dinamis.

 

image

Kesalahan konfigurasi FR dapat menyebabkan berbagai masalah yang berhubungan dengan jaringan. Beberapa masalah ini bisa diatasi hanya dengan mengikuti petunjuk dasar konfigurasi. Jika suatu jaringan frame relay mengalami banyak munculnya pesan notifikasi adanya kenaikan kongesi (red. membludaknya data transmisi) atau terasa lambatnya performa jaringan secara terus menerus, maka perlu diadakan kajian atas kebutuhan bandwidth circuit WAN yang mungkin perlu dinaikkan. Atau bahkan perlu pengkajian kalau saja ada masalah dengan design system anda yang menyebabkan mampetnya jalur circuit anda.

Konfigurasi Frame Relay

Berikut ini adalah tugas umum yang perlu dilakukan dalam konfigurasi frame relay.

  1.  Enable frame relay pada interface (serial S0 ataupun S1 dari router anda) dengan cara memilih jenis “Encapsulation type”
  2. Memberikan address network layer pada interface seperti IP address interface S0 atau S1
  3. Mengkonfigurasi address dynamic (menggunakan “inverse arp”) ataupun address statis (mapped interface)
  4. Untuk sub-interface Point-to-Point, atau sub-interface Multi-point dengan menggunakan dynamic address, gunakan DLCI pada sub-interface
  5. Untuk setting opsional gunakan LMI setting

 

By

Essay: 3. Interface pada PC dan Interface pada Cisco 2621

1. Pada komputer (PC) tentang : Serial interface, Parallel Interface, Ethernet, USB, SCSI, PCI.

Interface adalah istilah yang digunakan untuk pengantaraan atau antar muka atau dapat juga diartikan terhadap tampilan sebuah aplikasi yang dapat dilihat oleh manusia.. Antar muka yang dimaksudkan dapat berupa antara perangkat keras (hardware) dalam komputer, atau dapat berupa proses pengirim data melalui saluran telekomunikasi yang digunakan oleh manusia seperti telephone atau komunikasi seluler lain,

A. Serial Port

Serial Port atau biasa disebut dalam bahasa Indonesia adalah port seri merupakan sebuah port pada personal computer yang berfungsi untuk mentransmisikan satu bit informasi pada satu satuan waktu. Dalam serial port, pengiriman informasi tidak memungkinkan untuk melakukan secara banyak sekalius. Hal ini disebabkan karena dalam melakukan pemindahan data, biasanya serial port bekerja seri, misalnya COM 1 dan COM 2. Untuk penggunaan port serial sekarang ini sudah berkurang. Penggunaan port serial telah tergantikan dengan port USB dan Firewire. Sedangkan untuk jaringan (networking) fungsinya sudah tergantikan dengan port Ethernet. Berikut beberapa fungsi serial port yaitu menghubungkan antara peripheral (alat) computer lain dengan motherboard, penghubung antara mouse dengan motherboard, penghubung antara modem dengan motherboard, dan mentransmisikan informasi-informasi berupa bit-bit dari mainboard ke perangkat lainnya. Contoh Serial Port mouse dan scanner. Port Serial melakukan transmisi data pengiriman satu bit per satu waktu, karena sifatnya demikian pegiriman data berjalan agak lambat. Port ini sering dinyatakan dengan nama COM. Konektor yang digunakan adalah RS-232C terbatas hanya sampai puluhan dengan 9 pin atau 25 pin.
Biasanya digunakan untuk mengoneksi piranti seperti : printer, modem, PLC (programmable Logic controller), pembaca kartu magnetik dan pembaca barcode. 

B. Parallel Port

Parallel port atau biasa disebut dalam bahasa Indonesia adalah port paralel merupakan sebuah port pada personal computer yang berfungsi sebagai alat komunikasi komputer (motherboard) dengan perangkat luar yang bersifat paralel. Pada port paralel, pemindahan informasi dapat dilakukan secara bersamaan sehingga informasi yang terkirim lebih banyak daripada port seri. Port paralel biasa dikenal dengan Printer Port atau Centronics Port. Fungsi port paralel adalah sebagai penghubung motherboard dengan Printer jenis lama, Zip drive, beberapa Scanner, Sound Cards, Web Cams, Gamepads, Joystick, pemrograman EPROM, peralatan SCSI melalui adapter paralel ke SCSI, percobaan dengan TTL 12 driver, dan External CD-R atau CD-RW. Selain itu, port paralel juga digunakan sebagi uji coba sederhana dalam perancangan peralatan elektronika. Port Paralel atau sering disebut port LPT bekerja atas dasar 8 bit perwaktu, cocok untuk pengiriman data dengan cepat, tetapi dengan kabel yang pendek (tidak lebih dari 15 kaki). Umumnya digunakan untuk printer paralel, harddisk eksternal dan zip drive. Konektor yang digunakan adalah DB-25 yang terdiri dari 25 pin.

C . Port USB

Pengertian Port USB Menurut bahasa, Port USB terdiri dari dua kata, yang pertama Port adalah tempat untuk memasukkan kabel / peripheral lainnya ke computer kita, serta USB merupakan singkatan dari Universal Serial Bus dengan makna lain dapat dikatakan standar interface sebuah device, dengan kata lain pengertian dari Port USB adalah hubungan serial antara periferal dengan komputer. Port USB merupakan suatu teknologi yang memungkinkan kita untuk menghubungkan alat eksternal (peripheral) seperti scenner, printer, mouse, papan ketik (keyboard), alat penyimpan data (zip drive), flash disk, kamera digital atau perangkat lainnya ke komputer kita. Komputer (PC) saat ini, umumnya sudah memiliki port USB. Biasanya disediakan minimal 2 port. Jika dibandingkan dengan parallel port dan serial port, penggunaan port USB lebih mudah dalam penggunaannya. Konektivitas antara PC (Personal Computer) dengan perangkat USB dihubungkan dengan kabel khusus. Sebuah kabel berisi empat buah kawat menghubungkan periferal ke PC melalui port USB yang terdapat pada keduanya. Di dalam kabel tersebut, dua kawat akan menangani transmisi data, sebuah lagi menangani ground dan sebuah lagi memasok daya sebesar lima volt ke peripheral. Tentu sudah tidak asing lagi dengan port USB, dimana port ini merupakan port standart komputer untuk menghubungkannya dengan piranti lain. Port ini mempunyai kecepatan tinggi sesuai dengan versinya, bila dibandingkan dengan port serial maupun port paralel. Contohnya digunakan untuk camera digital, hardisk eksternal, keyboard mouse usb, modem dan peralatan tambahan komputer lainnya.

D. Port SCSI

PortSCSI atau Small Computer System Interface merupakan jenis port berkinerja tinggi yang didefinisikan oleh American National Standart Institute yang digunakan untuk menangani perangkat input/ouput atau perangkat media penyimpanan. Kecepatan transfernya 32 bit per waktu. Umumnya digunakan untuk menghubungkan hard drive, scanner, printer dan tape drive, konektor yang digunakan adalah DB-25 dan 50 pin Centronics SCSI.

E. Port LAN / Port network (RJ-45)

Port LAN atau lan card digunakan untuk mengubungkan komputer satu dengan lainnya yang membentuk jaringan komputer dalam suatu wilayah. Jaringan LAN biasanya hanya mencakup satu gedung rumah, misalnya jaringan LAN di kantor, hotel, bandara, warnet dll. RJ45 adalah jenis konektor yang digunakan untuk koneksi Ethernet pada komputer dan perangkat jaringan Ethernet lainnya seperti router, modem, dan perangkat lain mendukung interface Ethernet

F. Port PCI

PCI (kepanjangan dari bahasa Inggris : Peripheral Component Interconnect) adalah bus yang didesain untuk menangani beberapa perangkat keras. Standar bus PCI inidikembangkan oleh konsorsium PCI Special Interest Group yang dibentuk oleh IntelCorporation dan beberapa perusahaan lainnya, pada tahun 1992. Tujuan dibentuknya bus ini adalah untuk menggantikan Bus ISA/EISA yang sebelumnya digunakan dalam komputer IBM PC atau kompatibelnya.Komputer lama menggunakan slot ISA, yang merupakan bus yang lamban. Sejak kemunculan-nya sekitar tahun 1992, bus PCI masih digunakan sampai sekarang, hingga keluar versi terbarunya yaitu PCI Express (add-on). Slot PCI adalah tempat/slot untuk modem,tv tuner,LAN card(Multi Fungsi)

2. Pada Router Cisco 2621 tentang :Serial Interface, Ethernet interface, Aux, Console.

Interface Pada Cisco Router

Serial Interface

Cisco router seri 2600 adalah router akses modular dengan koneksi LAN dan WAN yang dapat dikonfigurasi dengan cara modul dipertukarkan dan kartu antarmuka WAN.

Ethernet interface

Semua Cisco router seri 2600 termasuk tambahan 115Kbps pendukung pelabuhan Dial On Demand Routing, ideal untuk konektivitas back-up WAN. Interface fisik termasuk steker listrik untuk catu daya dan tombol power. Router memiliki dua Fast Ethernet (10/100 RJ-45) konektor untuk transfer data masuk dan keluar. Modul ini juga memiliki dua lainnya RJ-45 konektor pada panel belakang untuk konsol terminal untuk akses sistem lokal dan port tambahan untuk akses sistem remote atau cadangan panggilan menggunakan modem. Port 10/100Base-T LAN memiliki Link / Activity, 10/100Mbps, dan setengah / LED full duplex.

Aux

Interface dari router digunakan untuk menyambungkan koneksi ke luar. Ada 3 tipe interface: LAN, Wan dan console atau auxiliary (AUX). Interface LAN biasanya satu atau beberapa tipe ethernet atau token ring yang berbeda-beda. Tiap-tiap intreface memiliki chip controller yang berfungsi untuk menyambungkan sistem ke media. Interface LAN biasanya berupa fixed configuration atau modular. Interface WAN misalnya serial, ISDN dan integrated CSU. Sama dengan interface LAN, ia juga mempunyai chip controller. Interface Wan bisa berupa fixed configuration atau modular. Port Console atau AUX adalah prot serial yang digunakan untuk proses konfigurasi. Ia digunakan sebagai terminal dari komunikasi port pada komputer melalui modem.

Console

Console Application ( Aplikasi Konsol ) adalah baris perintah yang berorientansi aplikasi yang memungkinkan kita untuk membaca karakter dari konsol, menulis karakter ke konsol dan dijalankan dalam versi DOS. Aplikasi konsol ditulis dalam kode dan didukung oleh nama space System Console.

 

By

SKUP SATRIA

Hasil gambar untuk satria puji irawan

Hola nama saya satria puji irawan ,saya sedang mengikuti perkuliahan ILp Kelas SK202Z ( Interfacing ) yang dibimbing oleh Bapak. Ignatius Agus Supriyono,SKom.,MM.

No. Assignment Status grade
1 Students Agrrement ILP Tercapai  A+
2 Create SKUP at KL801.ilearning.me Tercapai  A+
3  Interface pada PC dn Interface Pada Cisco 2621 Tercapai
4  Interface dan Sub Interface Pada Cisco Router  Tercapai
5
6

By

Project TM2 – Muhammad Nur Rifai

Sebenarnya saya mendapatkan tugas Membuat rangkaian Line Folower / Object Avoider tetapi saya memilih membuat seven segment seperti beberapa teman yang membuat seven segment.

Ditugas seven segment ini kita diiharuskan menampilkan angka digital didalam seven segment yaitu angka dari 0 sampai 9, dengan cara menekan tombol 1 menampilkan angka 1 dan seterusnya…

Read More

By

Personal Project TM2 – Adit Satria Nurhuda

Assalamaualaikum Wr. Wb.

Melanjutkan project TM1 yang sebelumnya, kali ini Pak Ignatius memberikan tugas untuk membuat seven segment.

Tugas Mandiri TM2

( Bimbingan Dwi Agusti)

Tugas menyalakan 7 Segment dengan ketentuan sbb:

Jika ditekan tombol 1 akan menyala Angka “1”

Jika ditekan tombol 2 akan menyala Angka “2”

Dan seterusnya sampai angka “9”, dengan default angka “0” , maka bisa menyala 0,1,2,3,4,5,6,7,8,9 .

Read More

By

iSur

Pertanyaan : iSur

Status : Tercapai 100%

Pernyataan : Saya telah mengisi kuisioner dosen di dalam iSur

Pembuktian :